Problems Installing Java on macOS/OS X

Some questions require the Java™ plugin. On macOS™/OS X®, the version of this plugin that you can install is dependent on the version of macOS/OS X you are using.

Some older content requires Java.

The JME tool requires Java, version 1.6.0 through 1.7.35.

The Java plugin is not supported in Chrome, version 45 or later.

If you are using Google® Chrome™, also see Can't Open in Chrome.

macOS/OS X Version 10.7 ("Lion") and Later

Install Java 7 from www.java.com/getjava.
Note Java 6 and earlier is not supported.

OS X Version 10.6 ("Snow Leopard") and Earlier

Use the OS X Software Update feature to ensure that you are running the most current version of Java 6.
Note Java 7 and later is not supported.